Банк рефератов содержит более 364 тысяч рефератов, курсовых и дипломных работ, шпаргалок и докладов по различным дисциплинам: истории, психологии, экономике, менеджменту, философии, праву, экологии. А также изложения, сочинения по литературе, отчеты по практике, топики по английскому.
Полнотекстовый поиск
Всего работ:
364150
Теги названий
Разделы
Авиация и космонавтика (304)
Административное право (123)
Арбитражный процесс (23)
Архитектура (113)
Астрология (4)
Астрономия (4814)
Банковское дело (5227)
Безопасность жизнедеятельности (2616)
Биографии (3423)
Биология (4214)
Биология и химия (1518)
Биржевое дело (68)
Ботаника и сельское хоз-во (2836)
Бухгалтерский учет и аудит (8269)
Валютные отношения (50)
Ветеринария (50)
Военная кафедра (762)
ГДЗ (2)
География (5275)
Геодезия (30)
Геология (1222)
Геополитика (43)
Государство и право (20403)
Гражданское право и процесс (465)
Делопроизводство (19)
Деньги и кредит (108)
ЕГЭ (173)
Естествознание (96)
Журналистика (899)
ЗНО (54)
Зоология (34)
Издательское дело и полиграфия (476)
Инвестиции (106)
Иностранный язык (62792)
Информатика (3562)
Информатика, программирование (6444)
Исторические личности (2165)
История (21320)
История техники (766)
Кибернетика (64)
Коммуникации и связь (3145)
Компьютерные науки (60)
Косметология (17)
Краеведение и этнография (588)
Краткое содержание произведений (1000)
Криминалистика (106)
Криминология (48)
Криптология (3)
Кулинария (1167)
Культура и искусство (8485)
Культурология (537)
Литература : зарубежная (2044)
Литература и русский язык (11657)
Логика (532)
Логистика (21)
Маркетинг (7985)
Математика (3721)
Медицина, здоровье (10549)
Медицинские науки (88)
Международное публичное право (58)
Международное частное право (36)
Международные отношения (2257)
Менеджмент (12491)
Металлургия (91)
Москвоведение (797)
Музыка (1338)
Муниципальное право (24)
Налоги, налогообложение (214)
Наука и техника (1141)
Начертательная геометрия (3)
Оккультизм и уфология (8)
Остальные рефераты (21697)
Педагогика (7850)
Политология (3801)
Право (682)
Право, юриспруденция (2881)
Предпринимательство (475)
Прикладные науки (1)
Промышленность, производство (7100)
Психология (8694)
психология, педагогика (4121)
Радиоэлектроника (443)
Реклама (952)
Религия и мифология (2967)
Риторика (23)
Сексология (748)
Социология (4876)
Статистика (95)
Страхование (107)
Строительные науки (7)
Строительство (2004)
Схемотехника (15)
Таможенная система (663)
Теория государства и права (240)
Теория организации (39)
Теплотехника (25)
Технология (624)
Товароведение (16)
Транспорт (2652)
Трудовое право (136)
Туризм (90)
Уголовное право и процесс (406)
Управление (95)
Управленческие науки (24)
Физика (3463)
Физкультура и спорт (4482)
Философия (7216)
Финансовые науки (4592)
Финансы (5386)
Фотография (3)
Химия (2244)
Хозяйственное право (23)
Цифровые устройства (29)
Экологическое право (35)
Экология (4517)
Экономика (20645)
Экономико-математическое моделирование (666)
Экономическая география (119)
Экономическая теория (2573)
Этика (889)
Юриспруденция (288)
Языковедение (148)
Языкознание, филология (1140)

Реферат: Разработка программного обеспечения корпоративной информационной системы

Название: Разработка программного обеспечения корпоративной информационной системы
Раздел: Рефераты по информатике
Тип: реферат Добавлен 01:56:19 28 июня 2011 Похожие работы
Просмотров: 1960 Комментариев: 2 Оценило: 0 человек Средний балл: 0 Оценка: неизвестно     Скачать

ФЕДЕРАЛЬНОЕ АГЕНТСТВО ПО ОБРАЗОВАНИЮ

ГОСУДАРСТВЕННОЕ ОБРАЗОВАТЕЛЬНОЕ УЧРЕЖДЕНИЕ

ВЫСШЕГО ПРОФЕССИОНАЛЬНОГО ОБРАЗОВАНИЯ

«ВОРОНЕЖСКИЙ ГОСУДАРСТВЕННЫЙ ТЕХНИЧЕСКИЙ УНИВЕРСИСТЕТ»

(ГОУВПО «ВГТУ»)

Естественно-гуманитарный факультет

(факультет)

Кафедра Систем автоматизированного проектирования и информационных систем

КУРСОВАЯ РАБОТА

по дисциплине Корпоративные информационные системы

Тема Разработка программного обеспечения корпоративной информационной сис­темы

Расчетно-пояснительная записка

Разработал студентка М.В.Козеева

Подпись, датаИнициалы, фамилия

Руководитель О.Г. Яскевич

Подпись, датаИнициалы, фамилия

Члены комиссии

Подпись, датаИнициалы, фамилия

Подпись, датаИнициалы, фамилия

Нормоконтролер ___________________________________________________

Подпись, датаИнициалы, фамилия

Защищена ____________Оценка_____________________________________________

дата

2010
ФЕДЕРАЛЬНОЕ АГЕНТСТВО ПО ОБРАЗОВАНИЮ

ГОСУДАРСТВЕННОЕ ОБРАЗОВАТЕЛЬНОЕ УЧРЕЖДЕНИЕ

ВЫСШЕГО ПРОФЕССИОНАЛЬНОГО ОБРАЗОВАНИЯ

«ВОРОНЕЖСКИЙ ГОСУДАРСТВЕННЫЙ ТЕХНИЧЕСКИЙ УНИВЕРСИТЕТ»

(ГОУВПО «ВГТУ»)

Кафедра инженерной экономики

ЗАДАНИЕ

на курсовую работу

по дисциплине Корпоративные информационные системы

Тема работы Разработка программного обеспечения корпоративной информационной системы

Студентка группы ИС-061 Козеева Мария Викторовна

Фамилия, имя, отчество

Номер варианта 1

Технические условия ПК с процессором Intel ® Pentium ® или AMD ® Athlon ® 1,8 ГГц или более мощным; операционная система Microsoft Windows XP или выше; 512 МБ ОЗУ .

Содержание и объем работы (графические работы, расчеты и прочее): объем работы -38 страниц, 14 рисунков, 3 таблицы .

Сроки выполнения этапов теоретическая часть-1.04.2010-10.04.2010; практическая . часть-12.04.2010-13.05.201 .

Срок защиты курсовой работы 17.05.2010 .

Исходные данные для ЭИП:

1. Количество филиалов: 2.

2. Территориальное размещение филиалов корпорации, км.: 5.

3. Количество отделов в филиале: 4.

4. Количество необходимых АРМ в отделе: 3.

5. Организационная структура корпорации: иерархическая.

6. Тип организации работ по проектированию КИС: 3.

7. Количество одновременно разрабатываемых проектов филиалом: 7.

8. Архитектура сети «клиент-сервер»: трехуровневая.

9. Метод передачи данных в сети: АТМ.

Руководитель О. Г. Яскевич

Подпись, дата Инициалы, фамилия

Задание принял студент М.В. Козеева

Подпись, дата Инициалы, фамилия


Замечания руководителя


Содержание

Задание на курсовую работу 2
Замечания руководителя 3
Введение 5
1 Описание предметной области 6
1.1 Организационная структура компании 6
1.2 Цели, назначения, задачи создания программного обеспечения ИС 7

1.3 Исследование и обоснование создания системы

1.3.1 Предварительное изучение предметной области

1.3.2 Проведение сбора и формализация материалов обследования

1.3.3 Анализ материалов обследования

8

8

11

13

1.4 Разработка технико-экономическогообоснования 14

1.5 Разработка технического задания

1.6 Создание эскизного проекта

1.7 Техническое проектирование ЭИС

15

17

18

2 Функциональное моделирование корпоративной ИС 19
2.1 Функциональная модель предметной области 19
2.2 Инфологическая модель предметной области 21
2.3 Даталогическое проектирование базы данных 22
3 Проектирование цифровой сети передачи данных корпоративной ИС 24
3.1 Архитектура «клиент-сервер» 24
3.2 Структура сети передачи данных 25
4 Описание программного средства 31
4.1 Выбор языка программирования 31
4.2 Контрольный пример 32
Заключение 34
Список литературы 35
Приложение А. Листинг программы 36

Введение

В современных условиях важной областью стало информационное обеспече­ние, которое состоит в сборе и переработке информации, необходимой для принятия обоснованных управленческих решений. Передача информации о положении и деятель­ности предприятия на высший уровень управления и взаимный обмен информа­цией между всеми подразделениями организации осуществляются на базе современной электронно-вычислительной техники и других технических средствах связи.

По мере своего дальнейшего развития административные системы обработки дан­ных перерастают в автоматизированные системы управления соответствующими объектами, в которых, как правило, не ограничиваются одной ЭВМ, а в составе двух и более ЭВМ объединяют в вычислительный комплекс.

Роль автоматизации документооборота заметно возросла в настоящее время. Для получения наиболее эффективного результата деятельности предприятия необхо­димо уменьшить затраты рабочего времени на обработку операции, тем са­мым увеличив количество обрабатываемых данных. Что дает для предприятия пря­мой экономический эффект.

Поэтому в настоящее время велика потребность предприятий в программном обеспечении, поддерживающим и согласующим работу управленческого и финансо­вого звеньев компании, а также в информации о способах оптимального использова­ния имеющегося у компании компьютерного оборудования.


1 Описание предметной области

1.1 Организационная структура компании

Целью данного курсового проекта является разработка программного продукта для салона красоты, позволяющего учитывать полный цикл взаиморасчетов с клиентом от момента записи до расчета за оказанные услуги. Автоматизация работы сотрудников салона.

Данная организация имеет 2 филиала, территориально размещенных на расстоя­нии 5 км. В каждом филиале имеется по 4 отдела, вмещающих 3 АРМ. Салон красоты имеет иерархическую организационную структуру.

Также должна быть организована трехуровневая струк­тура сети по типу “клиент-сервер”.

Рисунок 1 – Организационная структура компании

Бухгалтерия занимается составлением бухгалтерского отчета и расчетом заработной платы для сотрудников. Задача отдела кадров состоит в приеме на работу сотрудников салона. В отделе по работе с клиентами оформляются заявки клиентов на услуги. Маркетинговый отдел отвечает за контроль выполнения планов маркетинговых мероприятий, рекламу салона красоты и т.д.

1.2 Цели, назначения и задачи создания программного обеспечения информацион­ной системы

Целью создания программного обеспечения для салона красоты явля­ется автоматизация оформления заказа, переход с помощью разработанного программ­ного продукта к безбумажной форме документооборота, возможность сохране­ния заказа в единой базе данных.

В качестве задачи разработки программного продукта является создание КИС, пре­доставляющей наиболее полный спектр услуг в области автоматизированного оформления, в условиях максимальной оптимизации под разработанную для данной организации сеть. Разрабатываемый программный продукт представлен в форме прило­жения, как наиболее подходящей для внутренней сети организации, имеющей разнородное программное и техническое обеспечение.

После того как администратор войдет в приложение ему будет предоставлена форма для заполнения. Предоставляется выбор услуги, а также мастера и время посеще­ния салона, рассчитывается стоимость заказа, вносятся данные о клиенте.

Ниже приведены основные характеристики разрабатываемого программного про­дукта.

Требования к программе функционального характера:

1 Любое техническое устройство с выходом в сеть.

2 Любая ОС с установленным 1С предприятием.

В основе проектирования лежит модель жизненного цикла ЭИС. Процесс каскад­ного проектирования в жизненном цикле ЭИС делится на следующие семь ста­дий:

1 Исследование и обоснование создания системы.

2 Разработка технического задания.

3 Создание эскизного проекта.

4 Техническое проектирование.

5 Рабочее проектирование.

6 Ввод в действие.

7 Функционирование, сопровождение, модернизация.

Ниже будет рассмотрено проведение разрабатываемой КИС по всем этапам жиз­ненного цикла.

1.3. Исследование и обоснование создания системы

1.3.1 Предварительное изучение предметной области

Первым этапом в построении КИС занимается отдел сбора материалов обследова­ния, в функции которого входит предварительное изучение предметной области, уточнение границ изучения системы, определение круга будущей ЭИС различ­ных уровней и др.

Основной целью выполнения первого этапа предпроектного обследования "Сбор материалов" является:

1 Выявление основных параметров предметной области.

2 Установление условий, в которых будет функционировать проект ЭИС.

3 Выявление стоимостных и временных ограничений на процесс проектирова­ния.

При выборе типа технологий проектирования КИС остановимся на техноло­гии оригинального проектирования. Для технологии оригинального проектирования характерно создание уникального проектного решения для экономической системы конкретного предприятия. При этом могут создаваться не только индивидуальные проекты, но и соответствующие методики проведения проектных работ. Поэтому технологию оригинального проектирования используют в том случае, если хотят, чтобы получаемый в результате проектирования проект в полной мере отображал все особенности соответствующего объекта управления при невысокой стоимости разработки, понятности и доступности получаемого решения заказчику. К числу ограни­чений по использованию оригинального проектирования можно отнести низ­кую степень автоматизации проектных работ, длительные сроки разработки, низкое качество документирования, отсутствие преемственности в проектных решениях.

Далее выбираются методы проведения обследования:

1 По цели обследования – метод системного обследования объекта;

2 По числу исполнителей – индивидуальное обследование;

3 По степени охвата предметной области - метод сплошного обследования;

4 По степени одновременности выполнения работ первого и второго этапов пред­проектной стадии – метод последовательного проведения работ.

Выполнение работ по обследованию предметной области в каком-либо подразделе­нии и сбору материалов осуществляется методом сбора, выполняемого силами проектировщиков-исполнителей. Оно проводится по заранее разработанной программе, составляемой во время выполнения операции, по форме, представленной в таблице 1.

Для организации труда проектировщиков во время выполнения сбора материа­лов обследования и его последующего анализа необходима разработка «Плана-графика выполнения работ на предпроектной стадии» (таблица 2):

Таблица 1 –Программа обследования

Наименование вопроса Источник информации Получатель информации
1 Цель функционирования объекта Руководитель предприятия

Руководитель проекта

2 Основные параметры объекта Руководитель предприятия
3 Организационная структура объекта Заместитель руководителя
4 Функции, выполняемые в структурных подразде­лениях Заместитель руководителя
5 Описание хозяйственных процессов Специалисты предметной области
6 Описание структуры информационных и ма­териальных потоков Специалисты предметной области
7 Частоты возникновения потоков Специалисты предметной области
8 Направление движения потоков Специалисты предметной области

Таблица 2- План-график выполнения работ

Наименование работы Код работы Исполнитель Дата начала Длительность выполнения Дата окончания
1 Определение целей и параметров предпри­ятия 001 Руководи­тель про­екта Пет­ров П. П. 01.03.10 1 02.03.10
2 Определение организационный структуры предприятия 002 04.03.10 2 06.03.10
3 Описание хозяйствен­ных процессов на пред­приятии 003 06.03.10 2 09.03.10
4 Описание структуры информационных и ма­териальных потоков 004 09.03.10 3 12.03.10

1.3.2 Проведение сбора и формализация материалов обследования

В данном разделе сотрудники обязаны собрать сведения обо всех объектах иссле­дования, функциях предприятия, методах и алгоритмах реализации функций, разбив их на три группы форм. Первая: заказчик должен предоставить следующие данные о своей организации:

1 Наименование объекта и его принадлежность.

2 Тип предприятия.

3Вид производства.

4 Режимы работ.

5 Виды и номенклатура продукции и услуг.

6 Виды и количество оборудования и материальных услуг.

7 Количество отделов.

8 Численность работающих.

Описание организационной структуры должно включать состав и взаимосвязь под­разделений и лиц, реализующих функции и задачи управления. Описание производст­венной структуры объекта должно отражать состав и взаимосвязь подразделе­ний, реализующих производство товаров или услуг. Описание функциональ­ной структуры призвано отображать распределение функций, хозяйствен­ных процессов и процедур управления между составляющими организацион­ной структуры и должно предполагать проведение классификации проце­дур, связанных с обработкой данных, коммуникацией между сотрудниками или принятием управленческих решений.

Описание материальных потоков предполагает отображение маршрутов движе­ния средств, предметов и продуктов труда, рабочей силы между подразделе­ниями производственной структуры и будет включать: описание видов продукции или услуг, ресурсов; описание технологических операций, их частоту и длитель­ность выполнения; объемы перемещаемых ресурсов, продукции или услуг, используе­мые средства транспортировки.

Организационная структура салона – иерархическая, то есть полное подчине­ние по уровням иерархии. Отделы напрямую взаимосвязаны: без участия в работе одного, невозможно начало разработки другого отдела, так как проектирова­ние проходит последовательно все этапы, выполнение которых распределено по отде­лам.

Далее следует вторая группа форм, формализующих материалы обследования по каждому структурному подразделению, имеющая в своем составе, помимо форм, аналогичных тем, которые входят в первую группу, формы описания информацион­ных потоков по подразделениям, которые осуществляют связь задач внутри каждого подразделения между собой, а также связи между подразделениями.

Форма описания документопотоков включает следующие характеристики: наиме­нование входных документов, количество их экземпляров; объемные данные по каждому документопотоку; перечень информационных файлов, где использу­ются эти документы; носитель, на котором хранятся данные; время создания; время использования; перечень полей файлов; выходные документы, получаемые на ос­нове информации файлов.

Полученное в результате проведенной формализации описание объекта содер­жит исходные данные для проектирования ЭИС и определяет параметры будущей системы, которые далее будут обработаны в отделе анализа материалов обследова­ния.

1.3.3 Анализ материалов обследования

Для анализа материалов обследования необходимо получить, подготовленные на предыдущем этапе, данные об объекте и сопоставить их с теми требованиями, кото­рые к нему предъявляются заказчиком, кроме того, необходимо определить недос­татки функционирования объекта. На этом этапе идет работа с заказчиком, так как если есть разногласия, то дальнейшая работа нецелесообразна.

На основании анализа материалов обследования необходимо выделить и соста­вить список автоматизированных подразделений, учитывая при этом ряд следую­щих факторов:

а) количество формализуемых функций в каждом конкретном подразделении;

б) количество связей этого подразделения с другими подразделения;

в) важность этого подразделения в процессах управления объектом;

г) степень подготовленности подразделения для внедрения вычислительной тех­ники.

Следует выделить очередь проектирования решаемых задач. К задачам первой оче­реди относят самые трудоемкие задачи и задачи, обеспечивающие информацией все остальные задачи комплексов и подсистем. Общим требованием к первоочеред­ным задачам является получение нормативного коэффициента окупаемости капиталь­ных затрат.

Далее нужно предварительно выбрать комплекс технических средств (тип ЭВМ, ОС), предоставить информацию заказчику и, после получения согласия, продол­жить работу. Все полученные данные определяют и ограничивают проект ЭИС. Информация затем используется при разработке ТЭО и ТЗ.

1.4 Разработка технико-экономического обоснования

Разработка ТЭО начинается лишь после того, как вся информация о предпри­ятии проанализирована и выбраны основные технические средства.

Целью разработки «Технико-экономического обоснования» проекта ЭИС явля­ются оценка основных параметров, ограничивающих проект ЭИС, обоснование выбора и оценка основных проектных решений по отдельным компонентам проекта. При этом различают организационные параметры, характеризующие способы организа­ции процессов преобразования информации в системе, информационные и экономические параметры, характеризующие затраты на создание и эксплуатацию системы, экономию от ее эксплуатации. Основными объектами параметризации в системе являются задачи, комплексы задач, экономические показатели, процессы обработки информации.

Организационные параметры ЭИС для данной организации: фирма разбита на 2 филиала, в каждом из которых находится по 4 отдела; расстояние между филиа­лами составляет 5 км.

Экономические параметры: к ним можно отнести сметную стоимость разра­ботки проектов; нормативную прибыль; договорную цену разработки с учетом НДС; техническую прогрессивность; конкурентоспособность; годовые эксплуатационные издержки; экономическая эффективность проекта.

Прежде, чем разработчики перейдут к написанию ТЗ, следует, чтобы в ТЭО были описаны следующие показатели:

а) характеристика исходных данных о предметной области;

б) обоснование цели создания ЭИС;

в) обоснование автоматизируемых подразделений, комплекса автоматизируе­мых задач, выбора комплекса технических средств, программного и информацион­ного обеспечения;

г) разработка перечня организационно-технических мероприятий по проектирова­нию системы;

д) расчет и обоснование эффективности выбранного проекта;

е) выводы о техническом уровне проекта и возможности дальнейших разрабо­ток.

1.5 Разработка технического задания

Цель разработки

Целью работы является разработка программного средства для автоматизирован­ного управления салоном красоты, а также оптимизацией приема и обработки различных заявок, поступающих от клиентов и мастеров. На момент написа­ния технического задания система не имеет существующих аналогов. Целе­вой аудиторией являются работники салона красоты (Администратор, мастера, бухгал­тер), а также клиенты, посещающие данный салон красоты.

Назначение разработки

Разработать программный продукт для салона красоты, позволяющий учиты­вать полный цикл взаиморасчетов с клиентом от момента записи до расчета за оказан­ные услуги. Автоматизация работы сотрудников салона.

Систематизация работы с поставщиками. Решение вопроса расчета с персона­лом и хранения контактных данных сотрудников.

a) Анализ существующих потребностей заказчика в области автоматизирован­ного управления салоном.

b) Совместная разработка с заказчиком технического задания.

c) Разработка, программирование и отладка.

d) Написание документации.

e) Опытная эксплуатация.

f) Разработка, программирование и отладка рабочей версии на основе замеча­ний, полученных по результатам опытной эксплуатации.

Система должна содержать программу, которая выполняет следующие функции:

a) создание новой учетной записи клиента – анкеты, содержащий в себе: ФИО клиента, контактная информация, список услуг, выбранные клиен­тами, стоимость. Изначально информация о клиенте вносится в базу, затем добавляется в форму заявки;

b) формирование списка услуг;

c) определение даты выполнения заявки;

d) предварительный расчет суммы заказа.

Требование к функциональным характеристикам программы:

a) вывод стандартной цены заказа по наименованию;

b) вывод информации о сумме заказа;

c) вывод общей стоимости по заявкам;

Требования к обеспечению надежного функционирования программы

Надежное (устойчивое) функционирование программы должно быть обеспе­чено выполнением Заказчиком совокупности организационно-технических мероприя­тий, перечень которых приведен ниже:

a) организацией бесперебойного питания технических средств;

b) использованием лицензионного программного обеспечения;

c) регулярным выполнением рекомендаций Министерства труда и социаль­ного развития РФ, изложенных в Постановлении от 23 июля 1998 г. Об утверждении межотраслевых типовых норм времени на работы по сервисному обслуживанию ПЭВМ и оргтехники и сопровождению программных средств»;

d) регулярным выполнением требований ГОСТ 51188-98. Защита информа­ции. Испытания программных средств на наличие компьютерных вирусов

Время восстановления после отказа, вызванного сбоем электропитания техниче­ских средств (иными внешними факторами), не фатальным сбоем (не кра­хом) операционной системы, не должно превышать 30-ти минут при условии соблюде­ния условий эксплуатации технических и программных средств. Время восста­новления после отказа, вызванного неисправностью технических средств, фаталь­ным сбоем (крахом) операционной системы, не должно превышать времени, требуемого на устранение неисправностей технических средств и переустановки про­граммных средств.

Требования к интерфейсу:

a) поле выбора даты документа;

b) поле номера документа (автоматически);

c) поле выбора услуги;

d) поле выбора мастера;

e) поля выбора даты выполнения заказа;

f) поле вывода суммы

Минимально необходимыми для работы программного средства являются следую­щие параметры оборудования и операционной среды:

a) процессор типа IntelPentium, Celeron; AMDK5\K6, с тактовой частотой не ме­нее 450 МГц монитор типа VGA с разрешением 640x480 или выше;

b) 32-разрядная версия ОС Windows;

c) для Windows 9x: минимум 128 Мб оперативной памяти;

d) для WindowsNT: минимум 128 Мб оперативной памяти.

Программа должна обеспечивать одновременную работу нескольких пользовате­лей в одной системе пользователей.

1.6 Создание эскизного проекта

Отдел, занимающийся созданием эскизного проекта, получает утвержденное тех­ническое задание, после чего в его обязанности входит составление схемы организа­ционной структуры, структурного комплекса технических средств, схемы функциональной структуры, автоматизации. После того, как построены все схемы и графические приложения, информация передается в отдел технического проектирова­ния.

1.7 Техническое проектирование ЭИС

При техническом проектировании осуществляют логическую проработку функцио­нальной и системной архитектуры ЭИС, в процессе которой строится не­сколько вариантов всех компонентовсистемы; проводится оценка вариантов по показате­лям: стоимости, трудоемкости, достоверности получаемых результатов, и составляется «Технический проект» системы. Первым делом разрабатываются общесис­темные проектные решения.

Следующим этапом разработки является разработка локальных проектных реше­ний, в число которых входит разработка «Постановки задач» для задач, входя­щих в состав каждой функциональной подсистемы:

Таблица 3 – Постановка задач

Функциональная подсистема Поставленные задачи
1 Исследование и обоснование созда­ния системы Сбор данных об организации, анализ предметной области, утверждение ин­формации заказчиком.
2 Разработка ТЭО и ТЗ Определяются организационные, эконо­мические, информационные пара­метры ЭИС, разработка ТЗ
3 Создание эскизного проекта Построение схем и приложений струк­туры организации
4 Техническое проектирование Логическая проработка ЭИС, разра­ботка локальных проектных решений, перестроение организационной струк­туры

Также на этом этапе разрабатывается структура входных и выходных сообще­ний, проектируется состав и структура информационной базы, уточняется состав техни­ческих средств. Затем проект будущей КИС передается на рассмотрение заказ­чику.

2. Функциональное моделирование корпоративной ИС

2.1 Функциональная модель предметной области

Основу деятельности любой организации составляют ее деловые процессы или биз­нес-процессы, которые определяются целями и задачами организации. Каждый бизнес-процесс характеризуется четко определенным во времени началом и концом. Для каждой работы, входящей в бизнес-процесс, определены временные характери­стики, определяющие ее место в общей последовательности работ. Описание деятельно­сти организации с помощью бизнес-процессов позволяет определить где, когда и кем выполняется каждая функция, какие данные, информационные или функцио­нальные взаимосвязи для этого нужны и откуда эти данные поступают.

В данной курсовой работе рассматривается салон красоты. Можно выделить та­кие бизнес-процессы, как оформление услуги, оформление договора, и, в конечном итоге, определение прибыли.

Каждый бизнес-процесс в данном проекте характеризуется определенными во вре­мени началом и концом, внешними интерфейсами, которые либо связывают его с другими бизнес - процессами внутри организации, либо описывают выход во внеш­нее окружение, последовательностью выполняемых работ и правилами их выполне­ния (бизнес-правилами). Для каждой работы, входящей в бизнес-процесс, опреде­лены временные характеристики, определяющие ее место в общей последовательно­сти работ, условия инициализации и время выполнения.

В соответствии с описаннымибизнес-процессами построим, приведенные на рисун­ках 2, 3,4 диаграммы IDEF0.

Рисунок 2 - Контекстная диаграмма

Рисунок 3 – Детализация контекстной диаграммы

Рисунок 4 – Детализация процесса “Оформление заказа”

2.2 Инфологическая модель предметной области

Цель инфологического моделирования – обеспечение наиболее естественных для человека способов сбора и представления той информации, которую предполага­ется хранить в создаваемой базе данных. Поэтому инфологическую мо­дель данных пытаются строить по аналогии с естественным языком (последний не может быть использован в чистом виде из-за сложности компьютерной обработки текстов и неоднозначности любого естественного языка). Основными конструктив­ными элементами инфологических моделей являются сущности, связи между ними и их свойства (атрибуты). Инфологическая модель представлена в виде ER-диа­граммы, созданной в ErWin:

Рисунок 5 – Инфологическая модель предметной области

2.3 Даталогическое проектирование базы данных

В отличии от инфологической модели, которая осуществляет проектирование на логическом уровне, даталогическая модель позволяет рассматривать модель на физическом уровне. В реляционных БД даталогическое или логическое проектирова­ние приводит к разработке схемы БД, то есть совокупности схем отноше­ний, которые адекватно моделируют абстрактные объекты предметной об­ласти и семантические связи между этими объектами. Основой анализа корректно­сти схемы являются так называемые функциональные зависимости между атрибу­тами БД. Под процессом модификации БД понимается внесение новых данных в БД или удаление некоторых данных из БД, а также обновление значений некоторых атрибу­тов. Приведем даталогическую модель для данной организации:

Рисунок 6 – Даталогическая модель предметной области

3 Проектирование цифровых сетей передачи данных корпоративной информацион­ной системы

Корпоративная сеть – это инфраструктура организации, поддерживающая реше­ние актуальных задач и обеспечивающая достижение ее целей. Она объединяет в единое пространство информационные системы всех объектов корпорации. Корпора­тивная сеть создается в качестве системно-технической основы ИС.

3.1 Архитектура «клиент-сервер»

Организацию вычислений в рамках технологии «клиент-сервер», подразде­ляют на двухуровневую и трехуровневую архитектуры. Трехуровневая архитектура (рисунок 7) характеризуется тем, что: обработка информации выполняется на сер­вере приложений, а не на клиентских машинах. Таким образом, интерфейс пользова­теля, прикладные алгоритмы и работа с БД выполняют три самостоятельные компо­ненты. Каждая из них реализована на базе собственной программной и аппаратной архитектуры и выполняет свои определенные функции.

Рисунок 7- Архитектура «клиент-сервер»

3.2 Структура сети передачи данных

Для организации-заказчика разработана, приведенная ниже на рисунках, струк­тура сети.

По заданию основой сети проектной организации является сеть АТМ. Данный вид сети используется для связи между корпусами и приведен на рисунке 8.

Рисунок 8 – Организация сети между филиалами

Для разграничения сетевого трафика внутри корпуса от внешней сети использу­ется маршрутизатор (Router), который помимо этого позволяет уберечь сеть корпуса от пакетного шторма в случае неполадок во внешней сети. Все помеще­ния корпуса соединены между собой концентратором (Switch) и работают по сетевой технологии на тонком коаксиальном кабеле с пропускной способностью 10 Mbit/s. Расположенные в помещениях АРМ обмениваются с сервером приложений транзакциями по 50 байт через каждые 1 с, представляющими собой HTTP-трафик. К серверу приложений, расположенному в первом корпусе обращаются как АРМ из первого, так и из второго корпусов. Структура сети в первом корпусе приведена на рисунке 9.

Рисунок 9 – Организация сети первого корпуса

Структура сети второго корпуса приведена на рисунке 10.

Рисунок 10 – Организация сети второго корпуса

Все помещения корпусов организованы единообразно. АРМ соединены между со­бой с помощью центрального концентратора. Структура сети помещений приве­дена на рисунке 11.

Рисунок 11 – Организация сети типового помещения

Относительно молодая технология АТМ, в отличие от традиционных сетевых тех­нологий, ориентирована на соединение. Поэтому перед тем, как передать информа­цию между пользователями, организуется виртуальный канал, который дейст­вует до момента окончания передачи. Это несколько напоминает телефонную сеть, то есть для каждой взаимодействующей пары пользователей организуется выделен­ная полоса пропускания с заранее заказанными характеристиками (ширина полосы пропускания, максимальные задержки при передаче и т.д. — такая опция называ­ется QoS (QualityofService) и описана ниже). При этом весь разнородный тра­фик преобразуется в 48-байтовые ячейки, к которым добавляются 5-байтовые заго­ловки.

В настоящий момент поддерживаются скорости передачи в опорной сети 155 Мбит/с и 622 Мбит/с, но существует и оборудование, рассчитанное на передачу 2,4 Гбит/с. Появление более высокоскоростных устройств затрудняется сложностью техно­логии; кроме того, стоимость такого порта на порядки выше порта DWDM мульти­плексора, что делает подобную систему нерентабельной.

В отличие от технологий, где применяется временное мультиплексирование (TDM), технология АТМ позволяет динамически изменять полосу пропускания, исполь­зуемую под определенный поток, что дает возможность эффективно использо­вать имеющиеся каналы связи. К тому же, предусмотрен развитый меха­низм предоставления качественного обслуживания.

Обеспечение режима QoS на 2-3-м уровне модели OSI является коренным отли­чием технологии АТМ от таких сетевых технологий, которые, независимо от ширины полосы пропускания, в принципе не могут предоставлять столь развитые возможности QoS. Это означает, что сегодня АТМ является единственной техноло­гией, позволяющей полноценно передавать интегральный трафик (голос, видео, дан­ные), одновременно удовлетворяя совершенно несовместимым требованиям к усло­виям передачи и жестким условиям в плане загрузки канала связи. Так, например, при передаче голоса или видео в реальном режиме времени очень актуальным стано­вится обеспечение гарантированной полосы пропускания и минимальных времен­ных задержек и потерь ячеек при передаче.

Основными устройствами сети АТМ являются АТМ-коммутаторы, отвечаю­щие за установление соединения между пользователями и за предоставление им при этом QoS .

Как уже отмечалось выше, организация полноценного АТМ-соединения, кроме организации физического канала (например, в 155 Мбит/с), предусматривает еще и выполнение некоторых крайне важных функций, в частности обеспечение QoS.

Перечислим типы QoS, принятые сегодня:

1 CBR (ConstantBitRate) — выделение канала с фиксированной пропускной спо­собностью и другими параметрами (предельно допустимая задержка при пере­даче данных, и т.д.), заказанными пользователем. Такой вид QoS лучше всего подхо­дит для передачи голоса.

2 RT-VBR (RealTimeVariableBitRate) — выделение канала с пропускной способ­ностью в пределах коридора (минимум-максимум) и другими параметрами (максимальная задержка при передаче, и т.д.), запрошенными пользователем. RT-VBR идеально подходит для передачи видео и голоса. Имеет жесткие требования к задержке при передаче (поскольку предназначается для передачи трафика в режиме реального времени).

3 NRT-VBR (NonRealTimeVariableBitRate) — VBR с ослабленными требова­ниями к задержке передачи. NRT-VBR может применяться для передачи ви­део и голоса, не требующих режима реального времени.

4 ABR (AvailableBitRate) — предоставление пользователю части физического ка­нала, оставшейся невостребованной; причем при установлении соединения пользова­тель задает максимальную и минимальную скорости передачи. Поскольку ABR не контролирует величину задержек передачи, этот режим рекомендуется приме­нять при передаче данных (то есть для трафика, не чувствительного к за­держке передачи).

5 UBR (UnspecifiedBitRate) — самый низкоприоритетный тип трафика. Не преду­сматривает гарантированного предоставления пользователю какой-либо по­лосы пропускания. Все зависит от того, имеется ли возможность предоставления пользо­вателю какого-либо канала.

6 UBR+ — модифицированный UBR, дополненный функцией IntelligentPacketDis­card. Это очень существенное дополнение позволяет при потере ячейки (напри­мер, при перегрузке) не передавать оставашиеся ячейки из этого же пакета (кроме последней ячейки пакета), так как пакет уже не подлежит восстановлению. Данная операция особенно важна при использовании такого низкопроиритетного режима, как UBR. Следовательно, применение UBR+ позволяет разгрузить физические ка­налы АТМ.

Основные преимущества технологии АТМ:

1 Динамическое управление полосой пропускания каналов связи.

2 Предоставление QoS для различных типов трафика.

3 Возможности резервирования каналов связи и оборудования.

4 Возможность интегрирования самых различных типов трафика, включая го­лос, данные, видео.

5 Возможность экономии полосы пропускания за счет специальных техноло­гий обработки голосового трафика.

6 Возможность эмуляции «прозрачных» каналов связи.

7 Совместимость с технологией FR и предоставление сервисов пользователям FR. - используя технологию MPLS (TagSwitching), сервис-провайдер, имеющий опор­ную сеть АТМ, может динамически коммутировать трафик IP по опорной сети АТМ в реальном масштабе времени. При этом появляется возможность предостав­лять необходимый QoS, соотнося уровни приоритезации IP И АТМ.

Недостатки технологии АТМ:

1 Сложность технологии.

2 Относительно высокие цены оборудования.

3 Недостаточная совместимость оборудования от различных производителей.

4 В специфических задачах (например, при частой передаче небольших объе­мов трафика) применение технологии АТМ может привести к неоправданно боль­шим задержкам при установлении соединений и к довольно высокому проценту служеб­ной информации, загружающей канал связи.

Использование технологии АТМ при построении опорной сети рекомендуется в следующих случаях:

1 Загрузка каналов близка к предельной.

2 Требуется передавать разнородный трафик с предоставлением различных клас­сов обслуживания (голос, данные, видео).

3 Доля голосового трафика в общей загрузке канала является существенной.

4 Возможны требования по предоставлению «прозрачных» каналов связи, напри­мер для соединения выносов АТС.

4 Описание программного средства

4.1 Выбор языка программирования

Для реализации проекта был выбран встроенный язык программирования 1С:Предприятие, как один из наиболее популярных и удобных средств разработки.

Средой исполнения языка является программная платформа «1С:Предприятие». Визуаль­ная среда разработки («Конфигуратор») является неотъемлемой частью па­кета программ «1С:Предприятие». Платформой предоставляется фиксированный на­бор базовых классов, ориентированных на решение типовых задач прикладной об­ласти:

a) Константа,

b) Справочник,

c) Документ,

d) Журнал документов,

e) Перечисление,

f) Отчет,

g) Обработка,

h) План счетов и др.

На основании базовых классов средствами визуального конфигурирования можно создавать любое количество порождённых классов (возможность определить новый класс программно — отсутствует). Допускается только одна явная ступень наследования классов. Как правило, объекты порождённых классов представляют собой записи (или некоторые наборы записей) в базе данных. Такие классы обра­зуют «Дерево метаданных». В терминах встроенного языка программирования 1С такие классы называются объектами метаданных. Основными видами объектов метадан­ных являются: Справочники, Документы, Отчеты, Обработки, Планы видов характеристик, Планы счетов, Планы видов расчета, Регистры сведений, Регистры накопления, Регистры расчета, Бизнес-процессы, Задачи.

4.2 Контрольный пример

Был реализован механизм проверки вводимых данных и механизм выдачи систем­ных сообщений. Всё это проектировалось и реализовывалось с учётом того требования, предъявляемого к системе, что интерфейс должен быть интуитивно понят­ным.

Рисунок 12 –Вход в приложение

Рисунок 13 – Оформление заказа

Рисунок 14 –Отчет по заказам


Заключение

В любой организации, как большой, так и маленькой, возникает проблема та­кой организации управления данными, которая обеспечила бы наиболее эффектив­ную работу. Небольшие организации используют для этого шкафы с папками, од­нако крупные корпоративные предприятия используют компьютеризированные сис­темы автоматизации, позволяющие эффективно хранить, извлекать информацию и управлять большими объемами данных.

Темпы внедрения новых технологий в компьютерной отрасли значительно увеличились. Компании, конкурирующие за рынки и прибыли, стремятся момен­тально реализовать технические новшества в аппаратных средствах, программном обеспечении и парадигмах вычислений, стимулирующих развитие всей технологии управления информацией. Однако для успешной реализации крупных систем управле­ния требуется применить нестандартный подход, творческое решение. Использо­вание основ эргономики при проектировании, реализации и внедрении сис­темы управления позволит решить многие «психологические» и «технологические» проблемы предприятий.

В данной курсовой работе были рассмотрены теоретические вопросы, связан­ные с построением информационной сети и использующей ее ресурсы КИС, методоло­гией IDEF0, ее основные элементы и понятия, декомпозиция бизнес-процес­сов на уровни. В практической части был организован бизнес-процесс автоматизи­рованного оформления заявки на предоставление услуги в салоне кра­соты, построена его концептуальная модель, выявлены сопутствующие бизнес-про­цессы.


Список литературы

1. Долгих Д. В., Хаустович А. В. Технологии проектирования корпоративных ин­формационных систем .-Воронеж, 2000.

2. Ландсберг С. Е. Проектирование сложных ИС.- Воронеж, 2002.

3. Яскевич О. Г. Корпоративные информационные системы. – Воронеж, 2004

4. Яскевич О.Г. Оперативный учет на базе платформы 1С:предприятие.-Воронеж, 2003

Приложение А (обязательное)

Листинг программы

Процедура ПриОткрытии()

ПриЗаписиПерепроводить(1);

КонецПроцедуры

Процедура Кол()

КолО=Окр(Кол*(Ед.Коэффициент),2,1);

Сумма=Окр(КолО*Цена,2,1);

КонецПроцедуры

Процедура Ед()

КолО=Окр(Кол*(Ед.Коэффициент),2,1);

Сумма=Окр(КолО*Цена,2,1);

КонецПроцедуры

Процедура Цена()

Сумма=Окр(КолО*Цена,2,1);

КонецПроцедуры

Процедура Мастера()

Договор=ПолучитьПустоеЗначение("Справочник.Договора");

КонецПроцедуры

Процедура Услуга()

Если Кол=0 Тогда

Кол=1;

КонецЕсли;

СпрЕд=СоздатьОбъект("Справочник.Единицы");

СпрЕд.ИспользоватьВладельца(Услуги);

СпрЕд.ВыбратьЭлементы();

Пока СпрЕд.ПолучитьЭлемент()=1 Цикл

Если СпрЕд.Ед=Услуги.ЕдИзм Тогда

Ед=СпрЕд.ТекущийЭлемент();

Прервать;

КонецЕсли;

КонецЦикла;

КолО=Окр(Кол*(Ед.Коэффициент),2,1);

Цена=Окр(Услуги.ЦенаР.Получить(ДатаДок),2,1);

Сумма=Окр(КолО*Цена,2,1);

КонецПроцедуры

// ********************

//

Процедура ОбработкаПроведения()

Если Мастера.Выбран()=0 Тогда

Предупреждение ("Мастер не выбран");

НеПроводитьДокумент();

КонецЕсли;

Если ДатаВып<ДатаДок Тогда

Предупреждение ("Неверная дата ");

НеПроводитьДокумент();

КонецЕсли;

Регистр.Расчеты.Мастера=Мастера;

Регистр.Расчеты.Услуги=Услуги;

Регистр.Расчеты.Сумма=Итог("Сумма");

Регистр.Расчеты.ФлагДвижения=1;

Регистр.Расчеты.ДвижениеПриходВыполнить();

КонецПроцедуры

********************

Процедура ДатаН()

ДатаК=ПолучитьДатуТА();

Если ДатаН>ДатаК Тогда

ДатаН=ДатаК;

КонецЕсли;

КонецПроцедуры

Процедура ДатаК()

Если ДатаК<ДатаН Тогда

ДатаК=ДатаН;

ИначеЕсли ДатаК>ПолучитьДатуТА() Тогда

ДатаК=ПолучитьДатуТА();

КонецЕсли;

КонецПроцедуры

Процедура Сформировать()

Запрос=СоздатьОбъект("Запрос");

ТЗ="

|Период с ДатаН по ДатаК;

|Контр=Регистр.Расчеты.Мастера;

|Дог=Регистр.Расчеты.Договора;

|Долг=Регистр.Расчеты.Сумма;

|Функция СумКонОст=КонОст(Долг);

|Группировка Контр упорядочить по Контр.Код;

|";

Если Запрос.Выполнить(ТЗ)=0 Тогда

Сообщить("Запрос не выполнен");

Возврат;

КонецЕсли;

ИтогоМы=0;

ИтогоНам=0;

Таб=СоздатьОбъект("Таблица");

Таб.ИсходнаяТаблица("");

Таб.ВывестиСекцию("Шапка");

Пока Запрос.Группировка("Контр")=1 Цикл

ТЭ=Запрос.Контр;

Долг=Запрос.СумКонОст;

Если ТЭ.ЭтоГруппа()=1 Тогда

НазГр=СокрЛП(ТЭ.Наименование);

Если Долг=0 Тогда

ИначеЕсли Долг>0 Тогда

Мы=Долг;

Нам=0;

ИначеЕсли Долг<0 Тогда

Мы=0;

Нам=-Долг;

КонецЕсли;

Таб.ВывестиСекцию("Группа"); Иначе

Наз="("+СокрЛП(Строка(ТЭ.Код))+")"+СокрЛП(ТЭ.Наименование);

Если Долг=0 Тогда

Продолжить;

ИначеЕсли Долг>0 Тогда

Мы=Долг;

Нам=0;

ИтогоМы=ИтогоМы+Мы;

ИначеЕсли Долг<0 Тогда

Мы=0;

Нам=-Долг;

ИтогоНам=ИтогоНам+Нам;

КонецЕсли;

Таб.ВывестиСекцию("Строка");

КонецЕсли;

КонецЦикла;

Таб.ВывестиСекцию("Итого");

Таб.ТолькоПросмотр(1);

Таб.ПараметрыСтраницы(1,100,1);

Таб.Показать("");

КонецПроцедуры

Оценить/Добавить комментарий
Имя
Оценка
Комментарии:
Где скачать еще рефератов? Здесь: letsdoit777.blogspot.com
Евгений08:51:51 19 марта 2016
Кто еще хочет зарабатывать от 9000 рублей в день "Чистых Денег"? Узнайте как: business1777.blogspot.com ! Cпециально для студентов!
12:07:05 29 ноября 2015

Работы, похожие на Реферат: Разработка программного обеспечения корпоративной информационной системы

Назад
Меню
Главная
Рефераты
Благодарности
Опрос
Станете ли вы заказывать работу за деньги, если не найдете ее в Интернете?

Да, в любом случае.
Да, но только в случае крайней необходимости.
Возможно, в зависимости от цены.
Нет, напишу его сам.
Нет, забью.



Результаты(150043)
Комментарии (1830)
Copyright © 2005-2016 BestReferat.ru bestreferat@mail.ru       реклама на сайте

Рейтинг@Mail.ru