Банк рефератов содержит более 364 тысяч рефератов, курсовых и дипломных работ, шпаргалок и докладов по различным дисциплинам: истории, психологии, экономике, менеджменту, философии, праву, экологии. А также изложения, сочинения по литературе, отчеты по практике, топики по английскому.
Полнотекстовый поиск
Всего работ:
364150
Теги названий
Разделы
Авиация и космонавтика (304)
Административное право (123)
Арбитражный процесс (23)
Архитектура (113)
Астрология (4)
Астрономия (4814)
Банковское дело (5227)
Безопасность жизнедеятельности (2616)
Биографии (3423)
Биология (4214)
Биология и химия (1518)
Биржевое дело (68)
Ботаника и сельское хоз-во (2836)
Бухгалтерский учет и аудит (8269)
Валютные отношения (50)
Ветеринария (50)
Военная кафедра (762)
ГДЗ (2)
География (5275)
Геодезия (30)
Геология (1222)
Геополитика (43)
Государство и право (20403)
Гражданское право и процесс (465)
Делопроизводство (19)
Деньги и кредит (108)
ЕГЭ (173)
Естествознание (96)
Журналистика (899)
ЗНО (54)
Зоология (34)
Издательское дело и полиграфия (476)
Инвестиции (106)
Иностранный язык (62792)
Информатика (3562)
Информатика, программирование (6444)
Исторические личности (2165)
История (21320)
История техники (766)
Кибернетика (64)
Коммуникации и связь (3145)
Компьютерные науки (60)
Косметология (17)
Краеведение и этнография (588)
Краткое содержание произведений (1000)
Криминалистика (106)
Криминология (48)
Криптология (3)
Кулинария (1167)
Культура и искусство (8485)
Культурология (537)
Литература : зарубежная (2044)
Литература и русский язык (11657)
Логика (532)
Логистика (21)
Маркетинг (7985)
Математика (3721)
Медицина, здоровье (10549)
Медицинские науки (88)
Международное публичное право (58)
Международное частное право (36)
Международные отношения (2257)
Менеджмент (12491)
Металлургия (91)
Москвоведение (797)
Музыка (1338)
Муниципальное право (24)
Налоги, налогообложение (214)
Наука и техника (1141)
Начертательная геометрия (3)
Оккультизм и уфология (8)
Остальные рефераты (21697)
Педагогика (7850)
Политология (3801)
Право (682)
Право, юриспруденция (2881)
Предпринимательство (475)
Прикладные науки (1)
Промышленность, производство (7100)
Психология (8694)
психология, педагогика (4121)
Радиоэлектроника (443)
Реклама (952)
Религия и мифология (2967)
Риторика (23)
Сексология (748)
Социология (4876)
Статистика (95)
Страхование (107)
Строительные науки (7)
Строительство (2004)
Схемотехника (15)
Таможенная система (663)
Теория государства и права (240)
Теория организации (39)
Теплотехника (25)
Технология (624)
Товароведение (16)
Транспорт (2652)
Трудовое право (136)
Туризм (90)
Уголовное право и процесс (406)
Управление (95)
Управленческие науки (24)
Физика (3463)
Физкультура и спорт (4482)
Философия (7216)
Финансовые науки (4592)
Финансы (5386)
Фотография (3)
Химия (2244)
Хозяйственное право (23)
Цифровые устройства (29)
Экологическое право (35)
Экология (4517)
Экономика (20645)
Экономико-математическое моделирование (666)
Экономическая география (119)
Экономическая теория (2573)
Этика (889)
Юриспруденция (288)
Языковедение (148)
Языкознание, филология (1140)

Реферат: Работа с табличным процессором Exce

Название: Работа с табличным процессором Exce
Раздел: Рефераты по информатике
Тип: реферат Добавлен 19:57:30 18 июня 2011 Похожие работы
Просмотров: 14 Комментариев: 2 Оценило: 0 человек Средний балл: 0 Оценка: неизвестно     Скачать

ФЕДЕРАЛЬНОЕ АГЕНТСТВО ПО ОБРАЗОВАНИЮ РФ

Мценский филиал образовательного учреждения

высшего профессионального образования

«Орловский государственный технический университет»

Кафедра информатики

КУРСОВАЯ РАБОТА

по информатике

Студент группы ЭК-1-57

Болотин В.Ю.

Направление: 521600 " Экономика"

Руководитель: Борисова Е. В.

Оценка защиты ____________________

«____»____________ 2010

2010

СОДЕРЖАНИЕ

Задание №1. Работа с табличным процессором Excel. 3

Задание №2. Работа с СУБД Access. 3

ЗАДАНИЕ №3. ПРОГРАММИРОВАНИЕ НА АЛГОРИТМИЧЕСКОМ ЯЗЫКЕ ПАСКАЛЬ. 3

литература.. 3


Задание №1. Работа с табличным процессором Excel

1.1 В среде Excel на Листе 1 была создана таблица : ячейки A3:D22, E1:I2 заполнялись вручную, а ячейки F7:J28 с помощью формул =ЕСЛИ(D3=$E$2;1;0) , =ЕСЛИ(D3=$F$2;1;0), =ЕСЛИ(D3=$G$2;1;0), =ЕСЛИ(D3=$H$2;1;0) и =ЕСЛИ(D3="н/я";1;0)

1.2 Используя встроенные функции Excel, были даны ответы на вопросы:

а) в ячейки A23:A29 было внесено текстовое пояснение; в ячейку B25 была внесена формула СУММ(E3:E22), в ячейку B26 поместили формулу СУММ(F3:F22), в ячейку B27 – СУММ(G3:G22), в B28 формула СУММ(H3:H22), а в ячейку B29 поместили формулу СУММ(I3:I22).

б) в ячейку B23 была внесена формула СЧЁТ(A3:A22).

Лист 1 переименован в Математика. Результат представлен на рисунке 1.

Рисунок 1 – Экзаменационная ведомость по математике

1.3 На Листе 2 (Информатика) подобным образом была создана таблица (рисунок 2).

Рисунок 2 – Экзаменационная ведомость по информатике

Для выполнения задания 1.4 и 1.5 был создан лист Стипендия.

Для нахождения среднего балла или задолженности по предмету в ячейку D2 занесена формула: =ЕСЛИ(ИЛИ(математика!D3=2;информатика!D3=2;математика!D3="н/я";информатика!D3="н/я");"задолжник ";СРЗНАЧ(математика!D3;информатика!D3)) и скопирована в ячейки D2:D21

Для начисления стипендии была в ячейку E2 занесена формула:

=ЕСЛИ(И(D2>=4;D2<="задолжник");"начислено";" ") и скопирована в ячейки E2:Е21

Для начисления надбавки в ячейку F2 занесена формула:

=ЕСЛИ(И(D2>4;D2<=" ");"+25%";" ") и скопирована в ячейки F2:F21. Результат представлен на рисунке 3.

Рисунок 3 – Итоговая стипендиальная ведомость

1.6 Для диаграммы динамики двух оценок была использована таблица вида:

Рисунок 4 – Результаты сдачи экзаменов по математике и информатике

Полученная диаграмма имеет вид, представленный на рисунке 5.

Рисунок 5 – Динамика экзаменационных оценок по предметам


Задание №2. Работа с СУБД Access

Для выполнения задания была создана новая база данных и для создания таблицы «Студенты групп» был произведен импорт внешних данных из созданной ранее электронной таблицы с листа «Математика». Изменена структура таблицы и добавлены поля:

Группа – текстовый;

Год рождения – числовой.

Создана новая таблица «группы». Структура таблицы имеет вид, представленный на рисунке 6.

Рисунок 6 – Структура «группы » в Конструкторе

Готовая таблица имеет вид, представленный на рисунке 7.

Рисунок 7 – Таблица «группы»

По этим таблицам была создана Схема данных и построена форма для ввода и редактирования данных «группы »

Далее была создана таблица «данные сессии». Структура представлена на рисунке 8.

Рисунок 8 - Структура «данные сессии» в Конструкторе

Готовая таблица имеет вид, представленный на рисунке 9.

Рисунок 9 – Таблица «Данные сессии»

Была создана новая Схема данных, представленная на рисунке10 и построена Общая форма ввода и редактирования данных

Рисунок 10 – Схема данных

Далее были созданы следующие запросы:

Должники по каждому предмету (рисунок 11-13).

Рисунок 11 – Структура запроса Должники по математике

Рисунок 12 – Структура запроса Должники по информатике

Рисунок 13 – Структура запроса Должники по микроэкономике

Статистика по студентам хорошистам и отличникам (рисунок 14).

Рисунок 14 - Структура запроса Хорошисты и отличники

Рисунок 15 - Средний балл по каждой группе

ЗАДАНИЕ №3. ПРОГРАММИРОВАНИЕ НА АЛГОРИТМИЧЕСКОМ ЯЗЫКЕ ПАСКАЛЬ

В заданной целочисленной матрице 6x6 вывести индексы всех ее седловых точек (элемент матрицы называется седловой точкой, если он является наименьшим в своей строке и одновременно наибольшим в своем столбце, или наоборот, наибольшим в своей строке и наименьшим в своем столбце).

3.1 Программа на языке Паскаль

Исходный текст

program new;

const size = 6;

type point = record

x:integer;

y:integer;

value:integer;

end;

var count:integer;

var arr:array[1..size] of array [1..size] of integer;

var arr1:array[1..size] of array [1..size] of integer;

var maxString: array[1..size] of point;

var minString: array[1..size] of point;

var maxCol : array[1..size] of point;

var minCol : array[1..size] of point;

var t:integer; i:integer; j:integer;

var result:array[1..size*size] of point;

begin

count := 0;

for i:=1 to size do

begin

for j:=1 to size do

begin

writeln('vvedite ',j,' element ',i,' stroki');

readln(arr[i][j]);

end;

end;

for i:=1 to size do

begin

for j:=1 to size do

begin

write(arr[i][j]:5,' ')

end;

writeln;

end;

for i:=1 to size do

begin

maxString[i].y := 1;

maxString[i].value := arr[i][1];

minString[i].y := 1;

minString[i].value := arr[i][1];

for j:=1 to size do

begin

maxCol[j].y := 1;

maxCol[j].value := arr[1][j];

minCol[j].y := 1;

minCol[j].value := arr[1][j];

if(arr[i][j]>maxString[i].value)

then

begin

maxString[i].value := arr[i][j];

maxString[i].y := j;

end;

if(arr[i][j]<minString[i].value)

then

begin

minString[i].value := arr[i][j];

minString[i].y := j;

end;

end;

end;

for j:=1 to size do

begin

maxCol[j].y := 1;

maxCol[j].value := arr[1][j];

minCol[j].y := 1;

minCol[j].value := arr[1][j];

for i:=1 to size do

begin

if(arr[i][j]<minCol[j].value)

then

begin

minCol[j].value := arr[i][j];

minCol[j].y := i;

end;

if(arr[i][j]>maxCol[j].value)

then

begin

maxCol[j].value := arr[i][j];

maxCol[j].y := i;

end;

end;

end;

Программа разработана для ПЭВМ типа IBMPC и отлажена в среде Turbo-Pascal.

Программа почти полностью соответствует приведенной ниже блок-схеме.


3.2 Блок-схема программы


3.3 Результаты расчета

После компиляции и запуска программы произведено задание исходных данных и получен требуемый результат.

Экран работы программы имеет вид:

литература

1. Гладкий, А.А. Excel. Трюки и эффекты [Текст]/ А.А. Гладкий. – СПб.: Питер, 2006. – 368 с.: ил.

2. Информатика и информационные технологии [Текст]: учебное пособие/ под ред. Ю.Д. Романовой. – 3-е изд., перераб. и доп. – М.: Эксмо, 2008. – 592 с.

3. Информатика:Практикум по технологии работы на компьютере [Текст]/ под ред. Н.В. Макаровой. - 3-е изд., перераб. - М.: Финансы и статистика, 2005. - 256 с.: ил.

4. Немнюгин, С.А. Turbo Pascal. Программирование на языке высокого уровня [Текст]/ С.А. Немнюгин. - СПб.: Питер, 2003. - 544 с.

5. Симонович, С.В. Информатика: Базовый курс [Текст]: учебник/ С.В.Симонович. – М.: АСТ, 2002. – 640 с.

6. Соболь, Б.В.Информатика [Текст]: учебник/ Б.В. Соболь. - 3-е изд., доп. и перераб. - Ростов н/Д: Феникс, 2007. — 446 с.

7. Степанов, А.Н. Информатика [Текст]: учебник для вузов/ А.Н. Степанов. - 4-е изд. - СПб.: Питер, 2006. — 684 с.

8. Угринович, Н.Д. Информатика и информационные технологии [Текст]: учебник для 10-11 классов/ Н.Д. Угринович. – М.: БИНОМ. Лаборатория знаний, 2003. – 512 с.: ил.

Оценить/Добавить комментарий
Имя
Оценка
Комментарии:
Где скачать еще рефератов? Здесь: letsdoit777.blogspot.com
Евгений07:51:19 19 марта 2016
Кто еще хочет зарабатывать от 9000 рублей в день "Чистых Денег"? Узнайте как: business1777.blogspot.com ! Cпециально для студентов!
11:27:30 29 ноября 2015

Работы, похожие на Реферат: Работа с табличным процессором Exce

Назад
Меню
Главная
Рефераты
Благодарности
Опрос
Станете ли вы заказывать работу за деньги, если не найдете ее в Интернете?

Да, в любом случае.
Да, но только в случае крайней необходимости.
Возможно, в зависимости от цены.
Нет, напишу его сам.
Нет, забью.



Результаты(150317)
Комментарии (1830)
Copyright © 2005-2016 BestReferat.ru bestreferat@mail.ru       реклама на сайте

Рейтинг@Mail.ru